22 lines
383 B
Nix
22 lines
383 B
Nix
{ ... }:
|
|
|
|
{
|
|
networking = {
|
|
interfaces.net0 = {
|
|
ipv4.addresses = [
|
|
{
|
|
address = "10.31.210.13";
|
|
prefixLength = 23;
|
|
}
|
|
];
|
|
};
|
|
defaultGateway = "10.31.210.1";
|
|
nameservers = [ "10.31.210.1" ];
|
|
};
|
|
|
|
systemd.network.links."10-net0" = {
|
|
matchConfig.MACAddress = "D2:10:33:B1:72:C3";
|
|
linkConfig.Name = "net0";
|
|
};
|
|
}
|