30 lines
607 B
Nix
30 lines
607 B
Nix
{ ... }:
|
|
|
|
{
|
|
networking = {
|
|
interfaces.net0 = {
|
|
ipv4.addresses = [
|
|
{
|
|
address = "10.31.208.24";
|
|
prefixLength = 23;
|
|
}
|
|
];
|
|
ipv6.addresses = [
|
|
{
|
|
address = "2a07:c480:0:1d0::66";
|
|
prefixLength = 64;
|
|
}
|
|
];
|
|
};
|
|
defaultGateway = "10.31.208.1";
|
|
defaultGateway6 = "2a07:c480:0:1d0::1";
|
|
nameservers = [ "10.31.208.1" "2a07:c480:0:1d0::1" ];
|
|
search = [ "z9.ccchh.net" ];
|
|
};
|
|
|
|
systemd.network.links."10-net0" = {
|
|
matchConfig.MACAddress = "7E:3C:F0:77:8A:F4";
|
|
linkConfig.Name = "net0";
|
|
};
|
|
}
|