22 lines
383 B
Nix
22 lines
383 B
Nix
{ ... }:
|
|
|
|
{
|
|
networking = {
|
|
interfaces.net0 = {
|
|
ipv4.addresses = [
|
|
{
|
|
address = "10.31.208.13";
|
|
prefixLength = 25;
|
|
}
|
|
];
|
|
};
|
|
defaultGateway = "10.31.208.1";
|
|
nameservers = [ "10.31.208.1" ];
|
|
};
|
|
|
|
systemd.network.links."10-net0" = {
|
|
matchConfig.MACAddress = "BC:24:11:F2:CF:8F";
|
|
linkConfig.Name = "net0";
|
|
};
|
|
}
|