30 lines
606 B
Nix
30 lines
606 B
Nix
{ ... }:
|
|
|
|
{
|
|
networking = {
|
|
interfaces.net0 = {
|
|
ipv4.addresses = [
|
|
{
|
|
address = "10.31.206.15";
|
|
prefixLength = 23;
|
|
}
|
|
];
|
|
ipv6.addresses = [
|
|
{
|
|
address = "2a07:c480:0:1ce::f";
|
|
prefixLength = 64;
|
|
}
|
|
];
|
|
};
|
|
defaultGateway = "10.31.206.1";
|
|
defaultGateway6 = "2a07:c480:0:1ce::1";
|
|
nameservers = [ "10.31.206.1" "2a07:c480:0:1ce::1" ];
|
|
search = [ "z9.ccchh.net" ];
|
|
};
|
|
|
|
systemd.network.links."10-net0" = {
|
|
matchConfig.MACAddress = "BC:24:11:79:D3:E1";
|
|
linkConfig.Name = "net0";
|
|
};
|
|
}
|