23 lines
439 B
Nix
23 lines
439 B
Nix
{ ... }:
|
|
|
|
{
|
|
networking = {
|
|
interfaces.net0 = {
|
|
ipv4.addresses = [
|
|
{
|
|
address = "172.31.17.160";
|
|
prefixLength = 25;
|
|
}
|
|
];
|
|
};
|
|
defaultGateway = "172.31.17.129";
|
|
nameservers = [ "212.12.50.158" "192.76.134.90" ];
|
|
search = [ "hamburg.ccc.de" ];
|
|
};
|
|
|
|
systemd.network.links."10-net0" = {
|
|
matchConfig.MACAddress = "BC:24:11:5F:A9:B7";
|
|
linkConfig.Name = "net0";
|
|
};
|
|
}
|