24 lines
393 B
Nix
24 lines
393 B
Nix
{ ... }:
|
|
|
|
{
|
|
networking = {
|
|
interfaces.net0 = {
|
|
ipv4.addresses = [
|
|
{
|
|
address = "10.31.208.12";
|
|
prefixLength = 23;
|
|
}
|
|
];
|
|
};
|
|
defaultGateway = "10.31.208.1";
|
|
nameservers = [
|
|
"10.31.210.1"
|
|
];
|
|
};
|
|
|
|
systemd.network.links."10-net0" = {
|
|
matchConfig.MACAddress = "BC:24:11:73:3E:F7";
|
|
linkConfig.Name = "net0";
|
|
};
|
|
}
|