June
c9310374af
- Move audio configuration into a service module to make it easily usable by multiple hosts. - Allow configuration of AirPlay 2 name. - Don't set MQTT topic of Shairport-Sync (AirPlay 2) explictly. Defaults to hostname now. - Don't set sound.enable anymore, since its not needed.
17 lines
238 B
Nix
17 lines
238 B
Nix
{ config, pkgs, lib, ... }:
|
|
|
|
with lib;
|
|
|
|
let
|
|
|
|
cfg = config.ccchh.services.audio;
|
|
|
|
in
|
|
|
|
{
|
|
config = mkIf cfg.enable {
|
|
# Disable IPv6, since Shairport-Sync doesn't work with IPv6. Unclear why.
|
|
networking.enableIPv6 = false;
|
|
};
|
|
}
|