forked from CCCHH/nix-infra
23 lines
406 B
Nix
23 lines
406 B
Nix
{ config, pkgs, ... }:
|
|
|
|
{
|
|
networking = {
|
|
interfaces.net0 = {
|
|
ipv4.addresses = [
|
|
{
|
|
address = "10.31.210.10";
|
|
prefixLength = 23;
|
|
}
|
|
];
|
|
};
|
|
defaultGateway = "10.31.210.1";
|
|
nameservers = [
|
|
"10.31.210.1"
|
|
];
|
|
};
|
|
systemd.network.links."10-net0" = {
|
|
matchConfig.MACAddress = "1E:EF:2D:92:81:DA";
|
|
linkConfig.Name = "net0";
|
|
};
|
|
}
|