forked from CCCHH/nix-infra
June
f9fc034556
Also remove the upgrade script again. Bascially do steps 4 and 5 of the following section of the manual: https://nixos.org/manual/nixos/stable/#module-services-postgres-upgrading
19 lines
479 B
Nix
19 lines
479 B
Nix
{ pkgs, config, ... }:
|
|
|
|
{
|
|
services.postgresql = {
|
|
enable = true;
|
|
package = pkgs.postgresql_15;
|
|
|
|
initialScript = pkgs.writeText "synapse-init.sql" ''
|
|
CREATE ROLE "matrix-synapse" WITH LOGIN PASSWORD 'synapse';
|
|
CREATE DATABASE "matrix-synapse" WITH OWNER "matrix-synapse"
|
|
TEMPLATE template0
|
|
LC_COLLATE = "C"
|
|
LC_CTYPE = "C";
|
|
'';
|
|
|
|
dataDir = "/mnt/data/postgresql/${config.services.postgresql.package.psqlSchema}";
|
|
};
|
|
}
|