mirror of
https://forge.katzen.cafe/schrottkatze/nix-configs.git
synced 2024-11-05 15:16:23 +01:00
65 lines
2.1 KiB
Nix
65 lines
2.1 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{
|
||
config,
|
||
lib,
|
||
pkgs,
|
||
modulesPath,
|
||
...
|
||
}: {
|
||
imports = [
|
||
(modulesPath + "/installer/scan/not-detected.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = ["xhci_pci" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc"];
|
||
boot.initrd.kernelModules = ["i915"];
|
||
boot.kernelModules = ["kvm-intel"];
|
||
boot.extraModulePackages = [];
|
||
|
||
fileSystems."/" = {
|
||
device = "/dev/disk/by-uuid/4f9e8afa-f8d7-40bf-b3ea-17e8e8fbb694";
|
||
fsType = "btrfs";
|
||
options = ["subvol=@" "compress=zstd:3" "noatime"];
|
||
};
|
||
|
||
fileSystems."/home" = {
|
||
device = "/dev/disk/by-uuid/4f9e8afa-f8d7-40bf-b3ea-17e8e8fbb694";
|
||
fsType = "btrfs";
|
||
options = ["subvol=@home" "compress=zstd:3"];
|
||
};
|
||
|
||
fileSystems."/swap" = {
|
||
device = "/dev/disk/by-uuid/4f9e8afa-f8d7-40bf-b3ea-17e8e8fbb694";
|
||
fsType = "btrfs";
|
||
options = ["subvol=@/@swap" "noatime"];
|
||
};
|
||
|
||
boot.initrd.luks.devices."luks-9cd75cce-6829-4db8-8c5c-a9fb9ec3e122".device = "/dev/disk/by-uuid/9cd75cce-6829-4db8-8c5c-a9fb9ec3e122";
|
||
|
||
fileSystems."/boot" = {
|
||
device = "/dev/disk/by-uuid/C6CA-5DE8";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
swapDevices = [
|
||
{
|
||
device = "/swap/swapfile";
|
||
size = 1024 * 24;
|
||
}
|
||
];
|
||
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
# (the default) this is the recommended approach. When using systemd-networkd it's
|
||
# still possible to use this option, but it's recommended to use it in conjunction
|
||
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
||
networking.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.enp0s31f6.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.wlp2s0.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.wwp0s20f0u2i12.useDHCP = lib.mkDefault true;
|
||
|
||
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
||
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
|
||
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
}
|