mirror of
https://forge.katzen.cafe/schrottkatze/nix-configs.git
synced 2024-11-05 15:16:23 +01:00
22 lines
444 B
Nix
22 lines
444 B
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}: let
|
|
cfg = config.jade.desktop.syncthing;
|
|
in
|
|
with lib; {
|
|
options.jade.desktop.syncthing = {
|
|
enable = mkEnableOption "Enable syncing via syncthing";
|
|
};
|
|
config = mkIf cfg.enable {
|
|
services.syncthing = rec {
|
|
enable = true;
|
|
user = "jade";
|
|
dataDir = "/home/${user}/Documents";
|
|
configDir = "/home/${user}/Documents/.config/syncthing";
|
|
};
|
|
};
|
|
}
|