mirror of
https://forge.katzen.cafe/schrottkatze/nix-configs.git
synced 2024-11-05 15:16:23 +01:00
43 lines
1.2 KiB
Nix
43 lines
1.2 KiB
Nix
{config, ...}: {
|
|
home-manager.users.jade = {pkgs, ...}: {
|
|
# Needed for nu_scripts background_task
|
|
services.pueue = {
|
|
enable = true;
|
|
settings = {
|
|
shared = {
|
|
use_unix_socket = true;
|
|
};
|
|
};
|
|
};
|
|
home.packages = [
|
|
pkgs.pueue
|
|
];
|
|
home.file."shell-startup" = {
|
|
source = ../../other/scripts/desktop/shell-startup.nu;
|
|
target = ".config/nushell/shell-startup.nu";
|
|
};
|
|
programs.nushell = {
|
|
enable = true;
|
|
package = config.users.defaultUserShell;
|
|
configFile.source = ../../other/config.nu;
|
|
envFile.source = ../../other/env.nu;
|
|
extraConfig = ''
|
|
plugin add ${pkgs.nushellPlugins.query}/bin/nu_plugin_query;
|
|
plugin add ${pkgs.nushellPlugins.polars}/bin/nu_plugin_polars;
|
|
plugin add ${pkgs.nushellPlugins.formats}/bin/nu_plugin_formats;
|
|
|
|
plugin use query;
|
|
plugin use polars;
|
|
plugin use formats;
|
|
|
|
nu ${../../other/scripts/desktop/shell-startup.nu};
|
|
'';
|
|
extraEnv = ''
|
|
'';
|
|
};
|
|
# programs.starship.enableNushellIntegration = true;
|
|
programs.carapace.enableNushellIntegration = true;
|
|
programs.direnv.enableNushellIntegration = true;
|
|
};
|
|
}
|