46 lines
1.4 KiB
Nix
46 lines
1.4 KiB
Nix
{
|
|
description = "A simple NixOS deployment tool using nixos-rebuild internally, but trying to make infrastructure deployment more convenient.";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixos-23.11-small";
|
|
};
|
|
|
|
outputs = { nixpkgs, ... }:
|
|
let
|
|
version = "0.0.1";
|
|
in
|
|
{
|
|
packages = nixpkgs.lib.attrsets.genAttrs [ "x86_64-linux" "aarch64-linux" ] (system:
|
|
let
|
|
pkgs = nixpkgs.legacyPackages."${system}";
|
|
in
|
|
rec {
|
|
infra-rebuild = pkgs.python3Packages.buildPythonApplication {
|
|
pname = "infra-rebuild";
|
|
inherit version;
|
|
pyproject = true;
|
|
|
|
src = ./.;
|
|
|
|
nativeBuildInputs = with pkgs.python3Packages; [
|
|
hatchling
|
|
];
|
|
|
|
propagatedBuildInputs = [
|
|
pkgs.python3Packages.click
|
|
pkgs.nixos-rebuild
|
|
];
|
|
|
|
meta = with nixpkgs.lib; {
|
|
description = "A simple NixOS deployment tool using nixos-rebuild internally";
|
|
longDescription = "A simple NixOS deployment tool using nixos-rebuild internally, but trying to make infrastructure deployment more convenient.";
|
|
homepage = "https://git.hamburg.ccc.de/CCCHH/infra-rebuild";
|
|
license = licenses.gpl3Plus;
|
|
};
|
|
};
|
|
default = infra-rebuild;
|
|
}
|
|
);
|
|
};
|
|
}
|