mirror of
https://forge.katzen.cafe/katzen-cafe/katzen-cafe.git
synced 2024-11-05 07:26:23 +01:00
35 lines
795 B
Nix
35 lines
795 B
Nix
{
|
|
nixpkgsUnstable,
|
|
pkgsUnstable,
|
|
...
|
|
}: {
|
|
imports = [
|
|
"${nixpkgsUnstable}/nixos/modules/services/web-apps/invidious.nix"
|
|
];
|
|
disabledModules = [
|
|
"services/web-apps/invidious.nix"
|
|
];
|
|
services.invidious = {
|
|
enable = true;
|
|
domain = "catio.katzen.cafe";
|
|
serviceScale = 8;
|
|
http3-ytproxy.enable = true;
|
|
http3-ytproxy.package = pkgsUnstable.http3-ytproxy;
|
|
nginx.enable = true;
|
|
port = 3033;
|
|
settings = {
|
|
registration_enabled = true;
|
|
admins = ["adminkatze"];
|
|
banner = "Experimental katzen.cafe invidious instance! Meow!";
|
|
use_pubsub_feeds = true;
|
|
dark_mode = "dark";
|
|
force_resolve = "ipv6";
|
|
save_player_pos = true;
|
|
db = {
|
|
user = "invidious";
|
|
name = "invidious";
|
|
};
|
|
};
|
|
};
|
|
}
|