mail2-nixos-config/hopglass-frontend.nix
Daniel Frank b05d227a04
fu google
2021-05-01 18:42:06 +02:00

28 lines
680 B
Nix

{ config, lib, pkgs, ... }:
let
hopglass-fe = (pkgs.callPackage ./pkg-hopglass-fe.nix {
conf = ./hopglass-frontend.config.json;
} );
in
{
services.nginx.virtualHosts."map.hamburg.freifunk.net" = {
forceSSL = true;
enableACME = true;
default = true;
root = "${hopglass-fe}";
extraConfig = ''
access_log off;
add_header Permissions-Policy "interest-cohort=()" always;
'';
locations."/" = {
extraConfig = ''
index index.html;
etag off;
add_header etag "\"${builtins.substring 11 32 hopglass-fe}\"";
add_header Permissions-Policy "interest-cohort=()" always;
'';
};
};
}